Follow

TrueSight Pulse Browser Support

TrueSight Pulse works best on the latest versions of Chrome or Firefox running on Windows or macOS. Pulse may operate on other browsers such as Safari or Internet Explorer, but complete functionality is not guaranteed nor tested.

We make every attempt to provide the best support possible for older versions of Chrome and Firefox, but depending on the issue, upgrading to the latest version of the browser may be required.

Looking for browser options for TrueSight Intelligence?  Please look here: TrueSight Intelligence Browser Support 

Have more questions? Submit a request